Sorry, you need to enable JavaScript to visit this website.

Feedback

Your feedback is important to keep improving our website and offer you a more reliable experience.

Intel 945GM OpenGL 2.1

4 posts / 0 new
Diogo Rocha's picture
Starter
Diogo Rocha

May 30, 2013 - 06:49am

  • Hello! I have used the Graphics Installer in my Ubuntu 13.04 and after using the glxinfo command here is the result:

    OpenGL vendor string: Intel Open Source Technology Center
    OpenGL renderer string: Mesa DRI Intel(R) 945GM x86/MMX/SSE2
    OpenGL version string: 1.4 Mesa 9.1.1

    Mesa is updated but OpenGL looks to be at 1.4 (I think that's what this means).

    I'm trying to run the game Costume Quest, and it give me some messages:

    Your GL driver does not support ARB_half_float_vertex, and this title requires it.

    Your GL driver does not support ARB_texture_rg, and this title requires it.

    The game requirements are the following:

    Linux
    Processor: 1.4 GHz Dual-Core
    Memory: 1 GB
    Libraries: glibc 2.7+
    Graphics: 256 MB VRAM with OpenGL 2.1 capable and Compressed texture support (S3TC)

    My notebook is a old Toshiba Infinity IS-1451 with a core2duo and 2GB of RAM.

    So, Is there any way to get a better result for OpenGL with this 945GM?

    Edit: Let me ask it better: Can I force the GPU to use the OpenGL 2.1 or newer version by some software tweaking, config or compile (or whatever possible way)?

    May 30, 2013 - 06:49am
  • Quick note that I'm moving this thread to the Power Users forum, as this is not germane to the Graphics Installer. I'll explain in my next post.

    May 30, 2013 - 02:52pm
  • Hi diogoburgos,

    The version of mesa does not influence graphics hardware support for specific version of the OpenGL specification.

    Mesa drivers are written to the capabilities of the underlying graphics hardware. The mesa driver for your graphics hardware supports OpenGL 1.4. There exists no tweak to "force" support for newer versions of the OpenGL specification.

    Cheers

    May 30, 2013 - 03:08pm
  • Thank you for the quick answer. I'm just a little upset with the truth. Just one more question...

    This is also valid for shader languages?

    May 30, 2013 - 03:43pm
  • Hi diogoburgos,

    For all practical purposes, the answer is "yes." As mesa evolves, the shader compilers generally improve. However, support for the latest GL shader features require support from both your graphics hardware and its mesa driver.

    Cheers

    Jun 03, 2013 - 12:49pm
  • Topic locked